Cybrary is not working well for me

Cybrary is not working well for me. The labs for AWS are buggy and the pentest + has at least one fill in the blank in topic 4.2, question “3. Risk prioritization is often based on a ____________ framework to categorize vulnerabilities according to their severity.”, that will not register as correct even when the right answer is provided. I will need to find some other source that is more reliable and efficient to continue my training. It is also very difficult to impossible to get assistance with issues. I just recently stopped my subscription which is expensive.

I hope you find the training that suits your needs. Best of luck in your future endeavors!